Customer Manager Window

Purpose & Function

Customer Manager from the Home Page / Customers menu / "Customer List" menu item

The Customer Manager can be reached from the Main Application window (Customers menu / "Customer List" menu item), the Job Master window or the Project Manager window. From the Main Application window, it works as an address book for your clients allowing you to access and organize information for your clients. From the Job Master window and the Project Manager window the client manager acts as a client selector allowing you to select a client to assign to a job or project.

General Operation - The Customer Manager window contains a scrollable list of customers included in your database and a set of controls for sorting, searching and editing the items on the list.

Sorting the Customer Records

The gray column headings on the Customer List table are sorting buttons. Click once and the list will re-sort based on the data in that column, in ascending order. Click it again to reverse the sort order.

Filtering and Searching the Customer Records

The filtering controls consist of a Search utility. Open the Search utility by pressing the + button. Then select the parameter to search. By typing text into the field the clients list will be narrowed to only those records that begin with the text you typed.

###Adding New Customer Records To add a new customer record click the Add Customer button or click the Customer-Record menu / "Add New Customer" menu item. This will launch the Customer Record Details window to enter the new customer's information into. When this editor is closed the new record will be added to the Customer list.

###Editing Customer Records

To edit an existing customer record, you must first select the customer record on the customer list table. Then, click the Edit button or click the Customer-Record menu / "Edit Customer" menu item. This will launch the Customer Record Details window and load the customer's record for editing.

Copying Customer Records

Customer records can be copied by selecting the customer record from the table. Then, click the Customer-Record menu / "Copy Customer.

Deleting Customer Records

Generally it is unadvisable to delete customer records, especially if they are associated with jobs or projects. However, the need may arise to remove a record. To delete a customer record, select the record on the customer list table. Then click the Customer-Record menu / "Delete Customer" menu item.

Customer Selection Mode

Customer List, in Customer Selection mode

The Customer Manager is also used as a "Customer Selector" in certain parts of P3Expeditor. In selector mode a Current Selection box is shown at the top of the window. If this area is blank, no customer is selected. If a customer name appears in the field, that is the selected customer.

The Customer Selector is accessed from the Proposals and Invoices module (Job List button from the Home Page / double click on a job / from the Job Master window, click Project menu / "View Proposal" or "View Invoice" menu item / Customer button) or email module.

To make or modify your Customer Selection, simply find the desired customer on the scrollable list and double-click on that record. A pop-up window will confirm your choice, and the Current Selection box at the top of the screen should then reflect the new selection.

When the Customer Selector is closed, the Customer name in the "Selected Customer" box is returned for inclusion on the Job or Project that the Customer Selector was launched from.

Importing Customers

Customer contact information can easily be imported into the P3Expeditor Customer List from many common sources using the P3Expeditor Customer Importing Tool. This tool is accessed through the Customer Manager by clicking the Customer-List menu / "Import Customer Data" menu item.

Common Formats Data exported from MS-Outlook or MS-Outlook Express can be imported directly. Information in standard V-Card files can be imported directly.

Flexible Formats For data from other sources the Import function will accept tab delimited text files. These can be prepared using MS-Excel or other spreadsheet programs. For these delimited text files the column names must match a specific set of names and ordering.

The P3Expeditor format can be obtained by saving the file at this location => File:P3CustomerImportTemplate.txt or by using the "Get Import Template" menu function on the Customer List window. The resulting tab delimited text file has the column headings just as they should appear for importing.

Exporting Customers

The Customer List can be exported to a tab delimited text file. To do this click the Customer-List menu / "Export Customer Data" menu item. This will create an export file called "CustomerExport.txt". The file will be located in the same location as the P3Expeditor application file, called the P3Expeditor Installation Folder.

Print Customer List

This can be accomplished through the Customer-List menu through the Print List menu item.

Customer Details Window

Purpose & Function

Customer Record Details window from the "Add" or "Edit" buttons in the Customer Manager window

The Customer Record Details window pops up whenever you click the Add or Edit button from the Customer Manager window. This window allows you to edit the data for the individual customer records in your Customer List.

The fields on the Customer Record Details are used to label your Proposals and Invoices. While it is possible to enter only the Customer's email address and then send him/her a proposal or invoice, we recommend that you include enough information to properly identify the client in your documents.

Customer record information is also available for use in the email dialog address book and the Shipping Instructions address area. Customer records can now also be edited and created from the Shipping Instructions panel.

When you finish editing the client information, simply click the Save & Close button, and the data will be saved.

The Company Field

The Company field is used in many places within P3Expeditor to identify and select the customer record.

Customer Data and Job Records

When a customer is picked for a job, their data is copied to the job record as is. That way even if you delete the customer from your permanent record, the information will be retained with the job as long as it is in your archive.

Conversly, changes made to the Customer record after it is copied onto the job record will not be transferred to the job record. In order to refresh the data in a job with an existing customer selection, open the job and click the Search/Select button next to the Customer field. Then simply double click on the customer record to re-select it for the job. This will cause the information to be reloaded.

You can remove a customer from the Active list but unchecking the radio box labled Active (uncheck to remove from active list).

Business Information

You can enter further information on the company in the business information fields on the right side of the Customer Details Window.

Client Selection

Function & Purpose

Customer Manager in customer selection mode

When the Customer List is opened from a Job or Project (by clicking the Search/Select button next to the Customer field), the Customer Manager window pops up in Current Selection mode for the Job or Project it was opened from. The purpose is to enable the user to select a customer to be associated with the job or project they are working on. The customer currently associated with the job or project is displayed at the top of the window, above the Customer List table.

Selecting A Customer

To select a new customer, locate the customer record on the Customer List table and double-click it. A pop-up window will confirm your selection, and the display at the top of the window will reflect the change. Once the selection has been made, click the Close List button and the Customer Manager window will close. Your selected customer will be reflected in the job or project you are working on.